LOJA ONLINE

Acesse já e compre a melhor solução para você.

ACESSO RÁPIDO

Home

Thunder Cache

MK-Auth Cloud

Loja

Contato

Blog

CONTATO

MikrotikNet

Av. Praia de Belas 1212

Vitoria, ES

Ligue:  27 9 8176-1251

E-mail: danilo@mucurinet.com.br

Skype: Danilo Tomich

NEWSLETTER

Preencha seu e-mail para receber as novidades.

© 2016 MikrotikNet . Todos os direitos reservados.

Regras para MK-Auth Cloud

February 10, 2017

Regras para MK-AUth Cloud da Mikrotiknet.

 

Ao Adquirir o MK-auth Cloud, disponibilizamos um ip publico.

Portando nas regras abaixo substitua o ip: 172.31.255.1 para o ip publico que entregamos.

 

A conexão para autenticação do MK-Auth é feito por VPN. Portanto mude o user e senha da VPN

para o do seu cadastro.

A senha do ssh e a porta de acesso ao mk-auth solicite por favor. Por questões de segurança

não informamos aqui.

Comunicando Cloud com Mikrotik:

Por padrão o login da sua VPN será sempre "mkt1.nome.sobrenome".

A senha sempre: "sobrenome".

Caso tenha mais de um servidor de autenticação em sua rede, então precisa ser feito uma vpn para cada servidor de autenticação.

Para esse exemplo já deixamos configurado 5 conexões vpn para o MK-auth.

Da seguinte forma:

user: mkt1.nome.sobrenome

Senha: sobrenome

user: mkt2.nome.sobrenome

Senha: sobrenome

user: mkt3.nome.sobrenome

Senha: sobrenome

user: mkt4.nome.sobrenome

Senha: sobrenome

user: mkt5.nome.sobrenome

Senha: sobrenome

  • As regras abaixo é só copiar e colar no terminal do mikrotik.

  • Mais antes troque onde tiver em vermelho pelas informações do seu cadastro.

  • Se cada VPN é criada com user diferente, o ip de cada vpn é diferente também.

  • Para saber esse ip da vpn, após conectar a vpn no mikrotik, vai na vpn na opção status e copie o ip que esta em Local Address, e cole esse ip la no mk-auth no cadastro do terminal.

Abaixo regra para criar a VPN.

/interface pptp-client
add connect-to=172.31.255.2 disabled=no mrru=1600 name="MK-AUTH CLOUD MIKROTIKNET" password=sobrenome user=\
    mkt1.nome.sobrenome

Regra para comunicação via Radius.


/radius
add address=10.10.10.1 comment="MK-AUTH CLOUD MIKROTIKNET" secret=102030 service=ppp

Regras para PGcorte


/ip firewall nat
add action=dst-nat chain=dstnat comment="PG CORTE" dst-address=!172.31.255.2 dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85
add action=dst-nat chain=dstnat comment="PG CORTE HTTPS" dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=445

/ip firewall filter
add action=drop chain=forward comment=CORTE dst-address=!172.31.255.2 dst-port=!53 protocol=udp src-address-list=pgcorte
add action=drop chain=forward comment=CORTE dst-address=!172.31.255.2 dst-port=!80,85,443,445 protocol=tcp src-address-list=pgcorte

Cadastre Usuario do MK-auth no mikrotik.

A senha é a mesma que esta cadastrado no controle de servidores do mk-auth no campo: Senha MK-Auth.

/user
add address="" comment="NAO DESATIVAR E NAO MUDAR SENHA" disabled=no group=full name=mkauth

 

  • Após essas regras, não esqueça de baixar a chave do mk-auth, colar ela no file do mikrotik e ativar ela em system -> user -> ssh key

Click em import SSH Key, User: mkauth e key file a chave que esta no files.

 

  • Esse Script abaixo é para fazer backup automático do seu mk-auth para o mikrotik. Basta mudar a opção KEY do script para a que esta no cadastro do seu mk-auth, que se encontra em: PROVEDOR -> DADOS DA EMPRESA

TERÁ UMA OPÇÃO KEY API.


/system scheduler
add interval=12h name=ler_pppoe on-event="#===============================\r\
    \n:global IPMKAUTH \"10.10.10.1\"; \r\
    \n:global KEY \"a216269868e9dd505f2eb15c39f0396bi\"; \r\
    \n:global RAMAL \"todos\";\r\
    \n:global done \"\";\r\
    \n/tool fetch mode=http url=\"https://\$IPMKAUTH/mkt/pppoe.php\\\?key=\$KEY&ramal=\$RAMAL\" src-path=mkt_pppoe.php dst-path=mkt_pppoe.rsc;\r\
    \n:set done \"true\";\r\
    \n\r\
    \n:if ( [/file find name=mkt_pppoe.rsc] != \"\" ) do={\r\
    \n   :log warning \"Importando PPPoE\";\r\
    \n   /import mkt_pppoe.rsc;\r\
    \n   /file remove mkt_pppoe.rsc;\r\
    \n}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup

 

  • Regra abaixo é para monitorar seu cloud. Caso perca comunicação com ele por algum motivo, será ativado de forma automática os clientes no mikrotik.


/tool netwatch
add comment="PING PARA MK-AUTH" down-script="ppp secret set [/ppp secret find comment=mkauth] disabled=no\r\
    \n\r\
    \nip hotspot user set [/ip hotspot user find comment=mkauth] disabled=no" host=172.31.255.2 interval=5s up-script=\
    "ppp secret set [/ppp secret find comment=mkauth] disabled=yes\r\
    \n\r\
    \nip hotspot user set [/ip hotspot user find comment=mkauth] disabled=yes"

 

 

Tags:

mkauth cloud

regras mk-auth

regras mkauth cloud